amazon

Now Loading...

【解決】LollipopにしたらWiFi 5GHzが遅くて困った

昨年夏ごろ、我が家のXperia Z3 Tablet CompactをKitKatからLollipopへアップグレードしました。その時からず~っとおかしいと思っていたのですが、WiFi 5GHzでアクセスポイントと接続すると通信がとても遅くなるのです。

いろいろ検索して原因を探していたのですが、これといった解決策は見つかりませんでした。
しかし、Lollipopにすると5GHzでの通信が遅くなる現象は多くの方が陥っていることは判りました。
これはGoogleが対策してくれるのを待つしかないのでしょうか?
しかしMarshmallowでも同じ問題があるというような書き込みも見つかります。

久しぶりに意地になっていろいろ試してみたところ、5GHzで普通に通信する方法が見つかりました。



我が家では無線ルータにASUSのRT-AC68Uを使っています。IEEE 802.11acに対応し1300MHzの通信に対応するものです。アンテナの数は3本なので3x3 MIMOまで対応している事になるのでしょう。帯域幅は80MHzですね。

そしてXperia Z3 Tablet Compactの方は11acに対応しアンテナは2本あるようです。このため、RT-AC68Uとは2x2 MIMOで通信することになるでしょう。
帯域幅は80MHzなので最大866Mbpsのリンクができる事になります。数字だけ見るとすごい早いですね。無線では電波状態などの確認のための情報が多く必要なので、このリンク速度がそのままデータ通信速度になるわけではありませんが、十分なリンク速度ですね。

実際にルータの近くでWiFi 5Ghzに接続するとこのように表示されます。


リンクした直後は866Mbpsと表示されます。ルータから離れていくとリンク速度はすぐに433Mbps程度になります。2本のアンテナのうち1本はすぐに使わなくなってしまうのでしょうかね。
そして、我が家では家の中のほぼすべての場所で433Mbpsでリンクできています。

LollipopでのWiFi不具合

と、ここまでは無線ルータとのリンクの話です。
Webを見たりファイルのコピーを実際にする速度とはあまり関係がありません。
Z3 Tablet Compactを買った当時、KitKatのころは何の不都合もなくWiFi 5GHzで通信ができていました。しかし、昨年夏ごろLollipopが配信されOSをアップグレードすると5GHzではまともに通信できなくなってしまいました。

症状として、リンク速度は問題なし、Webを表示させると全く表示されないか一部しか表示されない、一瞬高速でWebが表示されるがすぐにデータがこなくなり残りの表示がされない、というような感じです。極めて重度のパケ詰まりのような雰囲気です。

何が原因なのでしょうか? 検索するとこの問題はLollipopが出た当初から話題になっていたようです。
Since Lollipop update WiFi issues
”… But since the update to Android 5.0 WiFi connectivity is really bad! Loading websites is much slower in the same room, where it was working fine with 4.4 and streaming via Chromecast became nearly impossible. …”

あぁ、これこれ。同じ症状かも。このスレッドは14年12月に書き込まれています。
どれどれ、解決策もあるのかな・・・と読み進めると
"The WiFi issues continue in Marshmallow (Android 6.0) on Nexus 5"
去年の11月になっても解決していないようです。しかもMarshmallowでもダメ?

IPv6が疑われていたが・・・

原因としてIPv6が上げられているフォーラムも見かけます。

Issue 79576:  Wifi slow if IPv6 enabled
”I have the same issue with my nexus 10.
I think it's a problem with ipv6 (and DNS ?) because when I use a vpn (which 'disables' ipv6) everything works fine.”
Android Open Source Project - Issue Tracker

これはさらに昔、パソコンでも問題になっていましたね。WindowsにIPv6の通信機能が付き始めたころです。NTTの光などでインターネットをつないでいるとIPv6のアドレスが自動的に付いてしまいます。ところが、IPv6はNTTの通信網の中だけしか通信できません。そんなことを知らないパソコンはWebページのアドレスをIPv6のDNSを使って探しに行きます。当然、アドレスは見つからず時間をかけた後にやっとIPv4のDNSを使ってアドレスを探しに行きます。
このようにどこか知らないWebアドレスを探す都度、無駄にIPv6への問い合わせをするためネット接続が遅くなったような症状に陥りました。
今はもうこの問題が起きることはないようです。

パソコンが通った道を遅れてスマホが辿っているのでしょうか?

いろいろなフォーラムを見ると、IPv6で通信できるネット環境を持っている人はちゃんとIPv6を使うように設定しろ、IPv6の無いネット環境の人はIPv6を無効に設定しろ、と。IPv6を無効にするにはroot化が必要です。普通はできません。そのため、仮想ネットワークを作りIPv6を使わない通信ルートを確保するアプリなども紹介されています。

ですが、私の問題とは違う感じがします。いろいろ実験しますが改善しません。そもそも、DNSの問題ならば同じWEBアドレスで表示が途中で止まることはありえません。もうアドレスは判ったから表示を始めたのですから。広告などで他のアドレスの応答を待つこともあり得ますが、そんなのとは関係なく通信が遅くなります。

それに2.4GHzのWiFiではまったく問題が起きない事の説明もできません。

無線ルータのWiFi設定が怪しい気がする・・・

我が家の無線ルータはASUSのRT-AC68Uです。ファームウエアは最新のものにしてあります。WiFiの設定も多くの項目があります。デフォルトから変えない方が良いと設定画面に表示されいたりもします。当然のように私はいろいろいじくりまわしてデフォルトの設定が何だったか忘れています。

あるいはルータのファームウエアをアップデートした時に設定がおかしくなったのかもしれません。ファームウエアを更新したときは設定を初期化してやり直す方が良い場合もあります。それは新しい設定項目や古い項目の設定内容の保存方法に変更が生じている場合、古い項目を正しく引き継げない可能性があるからです。まぁ、普通は問題なく引き継げるように設計してるでしょうけど。

気持ち悪いのでファームウエアも入れ直して設定も工場出荷時に戻してからすべての設定をし直しました。サーバを立ち上げているので設定を再現するのは面倒でした。

これでWiFiの設定も工場出荷時に戻りました。余計な変更は加えずにZ3 Tablet Compactとつないでみましょう。
・・・
遅い
・・・
相変わらず5GHzではまともにネット通信ができません。2.4GHzでは快適に通信が行えます。

もう完全にあきらめてしまおうかと思い始めました。
別の情報として特定の無線通信用ICを使うルータは通信が遅くなるというような話も目にしました。
Atermに替えるか?

Disable beamforming !

あきらめムードの中、最後のあがきと設定をいじります。そういえば11acの機能のbeamformingって効いてるのかなあ? どうせ遅いから無効にしてみよ。
・・・
あれ? 速い?
・・・

設定を変えると最初の数秒だけ調子がいいこともあったなぁ。有効に戻してみよ。
・・・
遅いや。
・・・

もっかい無効に。
・・・
速い! 速い!
・・・

もうこれですね。RT-AC68Uの設定のワイヤレス - プロの中に"802.11ac Beamforming"という項目があります。通常は有効となっています。11ac公式の機能なので無効にしてみようなんて思っていませんでいた。これを無効に設定すると今までの問題が嘘のように現れなくなります。

同じ設定ページに"ユニバーサルビームフォーミング"という項目もあります。こちらは前から有効にしたり無効にしたりして試していました。しかし、この項目の設定は何の解決にもなりませんでした。

という事で、"802.11ac Beamforming"を無効に設定すれば5GHzのWiFi接続が異常に遅くなる問題は回避できるようです。

もしかしたらASUSとZ3 Tablet Compactの組み合わせのみの問題と解決方法かもしれませんが、あちこちのフォーラムの内容を見ると一番しっくりくる解決策だと思えます。

この解決策が本当だとすると正式な機能であるbeamformingに不具合がある事になります。ルータの問題でしょうか? Lollipopの問題でしょうか? という点も気になり始めます。

ダウンロードスピードの確認


どのくらいのダウンロードスピードになるかテストしてみました。
パソコンの共有フォルダをZ3 Tablet Compactのリモートシェア機能で開きます。1.4GBほどのビデオファイルをパソコンからZ3 Tablet Compactの内部メモリーへコピーしてみます。
この時の速度をRT-AC68Uのトラフィックモニターで表示してみました。
場所はルータのすぐ近くと1部屋挟んだ向こう側という感じの2か所、beamformingは有効と無効という4条件で試しました。

Beamforming Disabled Link 866Mbps

Beamformingは無効にし、ルータの近くでリンク条件の良い場合の転送速度です。リンク速度も866Mbpsに近い状態が続く場所です。


約10MB/sでファイルの転送が行われています。

Beamforming Disabled Link 433Mbps

Beamformingは無効にし、ルータから1部屋挟んだ部屋での場合の転送速度です。リンク速度は433Mbpsに近い状態が続く場所です。アンテナは1本しかつながらない感じの場所です。


約8MB/sほどのファイル転送が行われていいます。

Beamforming Enabled Link 866Mbps

Beamformingは有効にし、ルータの近くでリンク条件の良い場合の転送速度です。リンク速度も866Mbpsに近い状態が続く場所です。


約8MB/sほどでファイル転送が行われています。思ったより悪くない?

Beamforming Enabled Link 433Mbps

Beamformingは有効にし、ルータから1部屋挟んだ部屋での場合の転送速度です。リンク速度は433Mbpsに近い状態が続く場所です。アンテナは1本しかつながらない感じの場所です。


約2MB/s弱でファイル転送が行われています。転送が終わらないうちに表示がいっぱいになってしまいました。

結論

beamformingが有効であっても2x2MIMOのリンクができていると意外と問題がない感じです。しかしWebなどを見てみると引っかかる感じがします。

アンテナ2本でのリンクができないような離れた場所では急にネットの転送速度が落ちます。

今回のファイル転送の実験を始める操作ができなかったりもしました。それはファイル一覧の表示に時間がかかりアプリが落ちてしまったりしたからです。あからさまに操作性が悪くなります。
Webページなどは見る気すら起きなくなるほど表示されません。

beamformingを無効にすると、嘘のように引っかかる感じが無くなります。

リンク速度が半分になる離れた部屋でも転送速度は10MB/sと8MB/sで大差ありません。内部メモリーの書き込み速度は確かめていませんが、これが律速かもしれませんね。

このようにbeamformingを無効にすると通信速度の落ち込みが無くなります。しばらくはこの回避策が有効なようです。早く改善されることを期待します。

おまけ

2.4GHzでの通信速度も気になっちゃいますよね。先ほどの離れた部屋で2.4GHzでファイル転送した場合の結果も載せておきます。リンク速度は130Mbpsとなっていました。



6MB/s強という転送速度になりました。リンク速度は5GHzと比べてとても遅いですが実際の通信は快適です。グラフの凸凹も少なく安定感があります。
電子レンジとか近所で使われなければスマホにちょうど良いのは2.4GHz帯のようです。







コメント

  1. K様 ご連絡ありがとうございます。頂いたコメントは別途保存しております。記事と関連が無いため削除させていただきました。

    返信削除

コメントを投稿

amazon

Now Loading...

最近のコメント

Threaded Recent Comments will be here.